USB抜き差し検知 ヘルプ
本アプリは、パソコンに抜き差しされたUSBメモリを検知し、
指定アプリにドライブ番号を通知する、常駐型のセキュリティ対策ツールです。

近年、USBメモリを契機としたコンピュータウィルスへの感染や
情報の盗難など、外部媒体の不正使用が問題視されており、
本アプリにより検知した以下の内容
●抜き差し端末
●抜き差し日時
●ドライブ情報
を、デバイスログアプリにより所定の場所に記録することで、
使用状況の監視を行います。

オフィス内ネットワーク上の端末で、
内密に監視したい場合などにご利用ください。

© 2023 IT-brains Co.,Ltd.


ご使用になる前に
本アプリご使用の前に必ずお読み下さい。
はじめに
使用目的
アンインストール


はじめに

アプリケーション概要
本アプリは、パソコンに抜き差しされたUSBメモリを検知し、
指定アプリにドライブ番号を通知する、常駐型のセキュリティ対策ツールです。
動作環境

基本ソフトウェア
Windows 7 日本語版(SP1) 以降
最小稼動メモリ | USB抜き差し検知 13 MB以上
デバイスログ 3 MB以上
ハードディスク | 10 MB以上の空き容量

使用にあたっての注意事項

● | 本アプリの一部、又は全部を無断で複製・転載することは禁じられています。
● | 本アプリの使用に関して運用した結果の影響については責任を負いかねます。 あらかじめご了承ください。
● | 本アプリをサイバー犯罪など、不正に利用することを固く禁じます。
● | 内容について万全を期して製作しておりますが万一、不正な記載や誤り・記載漏れなど お気づきの点がありましたら製作元までご一報ください。


使用目的

ご使用にあたっての注意事項
1) デバイスログの削除対策について

デバイスログは、登録された『格納ディレクトリ』にログファイルを出力します。

『デバイスのディレクトリ内容を出力する』をオンに設定している場合、
内容により、大量のログを出力することがあります。

本アプリでログファイルを削除する機能はありませんので、
一定期間を経過したログの削除対応等をお願いいたします。

活用例
1) | ウィルス対策ソフトの起動
 | 差し込み通知の起動パスに、ウィルス対策ソフトを指定しておくと、 差し込み検知時に、対象ドライブのウィルス感染チェックを実行します。 ウィルス感染拡大のリスクを事前に防ぐ対策となります。
2) | デバイスログの集中管理
 | 格納ディレクトリに共有ディスクなどを登録すると、ログファイル名は ●コンピュータ名 ●ドライブ番号 ●検知日 で構成されてますので、他端末のログファイルと競合することなく、 USBの使用状況を集中的に把握することができます。


アンインストール

手順

以下の手順で、本アプリのアンインストールを行います。

1) | スタートメニューの『設定』をクリックします。
2) | 『アプリ』をクリックします。
3) | 『USB抜き差し検知』を選択し、アンインストールをクリックします。 手順に従って操作してください。
※ 導入後に作成したフォルダ／ファイルがある場合、この操作では削除できません。
この場合、手動で削除してください。


操作の説明
アプリの開始と終了
USB抜き差しの検知と通知
動作環境の設定
アプリ情報の表示


アプリの開始と終了

USB抜き差し監視の開始
本アプリはパソコンの起動時に自動的に起動し、USBメモリの抜き差し監視を開始します。

タスクトレイのUSB抜き差し検知を終了したなど、監視が終了状態である場合は、
プログラムメニューの『USB抜き差し検知』をクリックし、監視を再開します。

USB抜き差し監視の終了
タスクトレイの『USB抜き差し検知アイコン』を右クリックし、メニューを表示します。
メニューの終了をクリックすると、本アプリを終了します。

終了操作は『USB抜き差し検知アイコン』の左クリックでも同様に行えます。
メニューの終了をクリックすると、本アプリを終了します。


USB抜き差しの検知と通知

検知ドライブの通知判定
USBメモリの抜き差しを検知した際に、検知ドライブが通知除外の対象であるかを確認し、
『通知除外ドライブ』に登録されているドライブ番号であれば通知処理を中断します。

例えば『通知除外ドライブ』が上図のように設定されている場合に、
検知したドライブ番号が『A』であれば、通知しません。
差し込みドライブの通知

USBメモリの差し込みを検知した際に、差し込み通知の起動パスを順次実行します。
（起動パスが未設定の行は実行しません）

起動パスの引数として
●ドライブ番号
●1.差込
を引き渡します。
取り外しドライブの通知

USBメモリの取り外しを検知した際に、取り外し通知の起動パスを順次実行します。
（起動パスが未設定の行は実行しません）

起動パスの引数として
●ドライブ番号
●2.取外
を引き渡します。
デバイスログの出力

差し込みと取り外しの起動パスに『ItbDeviceLog.exe』を登録している場合、
デバイスログを『格納ディレクトリ』に出力します。

デバイスログは
●コンピュータ名_ドライブ番号_検知日.log
のファイル名で出力します。

デバイスログファイルに、以下の内容を設定に従って出力します。

●差し込み通知の場合
●取り外し通知の場合

本アプリの終了時に、以下のファイル名で終了メッセージを出力します。
●コンピュータ名_検知日.log


動作環境の設定

USB抜き差し検知の動作設定
タスクトレイの『USB抜き差し検知アイコン』を右クリックし、メニューを表示します。

メニューの『設定』をクリックし、設定画面を表示します。

入力項目 | 桁数 | 説明
差し込み通知 起動パス | 1024 | USBの差し込みを検知したときに起動するファイルパスを指定する。 存在するファイルパスを最大３つまで指定可能。
取り外し通知 起動パス | 1024 | USBの取り外しを検知したときに起動するファイルパスを指定する。 存在するファイルパスを最大３つまで指定可能。
選択ボタン | - | 起動パスファイルを選択するためのダイアログを表示する。
通知除外ドライブ一覧 | - | 通知を除外するドライブレター一覧を表示する。
通知除外ドライブ | 1 | 通知を除外するドライブレターを指定する。 追加ボタン押下で一覧の選択行下に追加する。
追加ボタン | - | 通知を除外するドライブレターをリストに追加する。 一覧に存在するドライブレターは指定できない。
削除ボタン | - | 通知除外ドライブ一覧の選択行を削除する。
設定ボタン | - | 入力内容を設定ファイルに保存し、画面を閉じる。
キャンセルボタン | - | 編集をキャンセルし、画面を閉じる。

デバイスログの動作設定
プログラムメニューの『USB抜き差し検知』をクリックし、サブメニューを表示します。

サブメニューの『デバイスログ設定』をクリックし、設定画面を表示します。

入力項目 | 桁数 | 説明
格納ディレクトリ | 1024 | ログインユーザーが書き込み可能な ログファイルを格納するディレクトリを指定する。
ログインユーザーを出力する | - | ログインユーザーを出力する場合に指定する。
ドライブ番号を出力する | - | ドライブ番号を出力する場合に指定する。
デバイスのボリューム情報を出力する | - | ボリューム情報を出力する場合に指定する。
デバイスのディレクトリ内容を出力する | - | デバイスのディレクトリ内容を出力する場合に指定する。
ディレクトリ内容の最大出力行数 | 8 | ディレクトリ内容の最大出力行数を指定する。 0を指定した場合、ディレクトリ内容を全行出力する。
設定ボタン | - | 入力内容を設定ファイルに保存し、画面を閉じる。
キャンセルボタン | - | 編集をキャンセルし、画面を閉じる。


アプリ情報の表示

USB抜き差し検知のアプリ情報
タスクトレイの『USB抜き差し検知アイコン』を右クリックし、メニューを表示します。

メニューの『アプリ情報』をクリックし、アプリ情報画面を表示します。

当画面では、以下の内容を確認できます。
●アプリ名とバージョン
●著作者名
●著作者URL

『著作者URL』のクリックで、著作者ホームページを表示します。

デバイスログのアプリ情報
設定画面の『システムメニュー』をクリックし、メニューを表示します。

メニューの『アプリ情報』をクリックし、アプリ情報画面を表示します。

当画面では、以下の内容を確認できます。
●アプリ名とバージョン
●著作者名
●著作者URL

『著作者URL』のクリックで、著作者ホームページを表示します。