IT用語集 ヘルプ
本アプリは
・ IPA (独立行政法人情報処理推進機構)
のホームページに掲載されている
● 基本情報技術者試験（レベル2）シラバス ver 9.1
● 応用情報技術者試験（レベル3）シラバス ver 7.1
を参考に、IT関連の用語を集約した電子書籍です。

● 情報処理技術者学習ノート
の後継として機能改善をしており、
・ 情報処理技術者試験対策
・ IT関連用語の検索エンジン
などの用途で、引き続きご使用いただけます。

用語知識の整理などに、ご活用ください。

また、本アプリのご使用にあたり、
● お使いになる前に
● 操作の説明
の方を必ず一読下さいますよう、お願いいたします。

© 2025 IT-brains Co.,Ltd.


お使いになる前に
本アプリご使用の前に必ず一読下さい。
はじめに
使用目的
アンインストール
ライセンスの登録


はじめに

アプリケーション概要
本アプリは
・ IPA 独立行政法人 情報処理推進機構
のホームページに掲載されている
● 基本情報技術者試験（レベル2）シラバス ver 9.1
● 応用情報技術者試験（レベル3）シラバス ver 7.1
を参考に、IT関連の用語を集約し、調査結果をまとめた電子書籍です。

● 情報処理技術者学習ノート
の後継として機能改善をしており、
・ 情報処理技術者試験対策
・ IT関連用語の検索エンジン
などの用途で、引き続きご使用いただけます。

用語知識の整理などに、ご活用ください。

動作環境

プラットフォーム
Windows10 以降
最小稼動メモリ | 150 MB以上
ハードディスク | 50 MB以上の空き容量

使用にあたっての注意事項
● | 本アプリは、著者が独自に調査した結果を掲載したもので ・ IPA 独立行政法人 情報処理推進機構 の活動とは関係ありません。
● | 内容に記載している ・ ハードウェア名 ・ ソフトウェア名 などは、一般に各メーカーの商標、又は登録商標です。 記載するにあたって、通称やその他の呼称を使用することがありますので、 あらかじめご了承ください。
● | 本アプリの一部、又は全部を、無断で複製・転載することは禁じられています。
● | 本アプリの使用に関して運用した結果の影響については責任を負いかねます。 あらかじめご了承ください。
● | 本アプリやヘルプについて、万全を期して製作しておりますが、万一 ・ 不正動作（不具合） ・ 不正な記載や誤り ・ 記載漏れ など、お気づきの点がありましたら製作元までご一報ください。


使用目的

収録出題範囲
本アプリに収録されているIT用語の、試験出題範囲は以下の通りです。

区分 | 試験名称 | 出題範囲
FE | 基本情報技術者 | 令和05年度 一部 ～ 令和06年度 一部 平成16年度 春期 ～ 令和元年度 秋期
AP SW | 応用情報技術者 ソフトウェア開発技術者 | 平成21年度 春期 ～ 令和07年度 春期 平成16年度 春期 ～ 平成20年度 秋期
高共 | 高度共通（午前Ⅰ） | 平成21年度 春期 ～ 令和07年度 春期
NW | ネットワークスペシャリスト | 平成16年度 秋期 ～ 令和07年度 春期
DB | データベーススペシャリスト | 平成16年度 春期 ～ 令和06年度 秋期
ES | エンベデッドシステムスペシャリスト | 平成16年度 春期 ～ 令和06年度 秋期
SC SC SV SU | 情報処理安全確保支援士 情報セキュリティスペシャリスト テクニカルエンジニア(情報セキュリティ) 情報セキュリティアドミニストレータ | 平成29年度 春期 ～ 令和07年度 春期 平成21年度 春期 ～ 平成28年度 秋期 平成18年度 春期 ～ 平成20年度 春期 平成16年度 秋期 ～ 平成20年度 秋期

注1) | 出題情報は可能な範囲で関連付けしております。
注2) | プログラム言語の仕様は、概要のみ掲載しております。

活用例

情報処理技術者試験の試験対策として、本アプリの活用一例を記述します。

1) | 理解度の確認 ・ IPA 独立行政法人情報処理推進機構 のホームページより過去問題をダウンロードし、本アプリを使用せずに自力で問題を解きます。 過去問題は新しいものより解いていき、出来るだけ多くの問題にトライします。 この時、確実に解答出来たものと、出来なかったものに分類します。 （確実に解答できなかったものを『不正解』とします）
2) | 不正解の解決 不正解となった問題全てについて、本アプリを使用して解決していきます。 ※ここでは不正解となった問題を ・出典：令和4年 春期 応用情報技術者試験 午前 問4 とした場合、以下の抽出条件で検索します。
 | 不正解を解決するまで、繰り返し黙読します。
3) | 最終確認 過去問題をもう一度解いていき、不正解がなくなったことを確認します。 ここで不正解となった問題を、徹底的に追及します。
4) | 未出題ページの黙読 一般に過去問題の出題率は『70%』程度と言われてますが、 本アプリの用語データを作成している限りでは『妥当な出題率』と感じられます。 残り『30%』も正解できるよう、時間の許す限り未出題ページの黙読をお勧めします。


アンインストール

手順
以下の手順で、本アプリのアンインストールを行います。

1) | スタートメニューの『設定』をクリックします。
2) | 『アプリ』をクリックします。
3) | 『IT用語集』を選択し、アンインストールをクリックします。 手順に従って操作してください。
※ 導入後に作成したフォルダ／ファイルがある場合、この操作ではフォルダ／ファイルを削除しません。
この場合、フォルダ／ファイルは手動で削除してください。


ライセンスの登録

手順

以下の手順で本アプリのライセンス登録を行い、正規版に切り替えます。

本アプリは、一定期間試用できますが、
試用期限を超過すると『期限切れ』となり、ご使用できなくなりますのでご注意ください。

1) | 本アプリメニューの『ヘルプ』をクリックし、『バージョン情報』を選択します。
2) | ライセンスキーを登録するボタンをクリックします。
3) | 入手したライセンスキーと使用者を20文字以内で入力し、登録ボタンをクリックします。
4) | メッセージの表示で『登録完了』となります。 本アプリを再起動してください。
5) | 本アプリを正規版で起動します。


操作の説明

画面の表示
本アプリを起動し、操作画面を表示します。
操作の説明
画面の構成
目次の操作
抽出条件の検索
データの出力
しおり設定
設定
ヘルプ
アプリ情報
閉じる


画面の構成

アプリ起動

プログラムメニューの『IT用語集』をクリックし、本アプリを起動します。

起動時に『起動処理ダイアログ』を表示します。

起動処理の完了で、メイン画面の操作が可能となります。

メニューバー

メニューを選択し、本アプリの操作や設定等を行います。

メニューバーの構成は、以下のとおりです。

メニュー | 説明
ファイル(F) ┗しおり(M) ┗[ ]未読(S) ┗[❖]読中(B) ┗[✓]既読(A) ┗[◎]他(O) ┗閉じる(C) | しおりを設定します。 読取モードを未読に設定します。 読取モードを読中に設定します。 読取モードを既読に設定します。 読取モードを他に設定します。 本アプリを終了します。
表示(V) ┗目次の展開(E) ┗目次の折畳(C) ┗最新の情報に更新(R) | 目次を展開します。 目次を折り畳みます。 読取モードを最新の状態に更新します。
ツール(T) ┗設定(S) ┗導入時の設定に戻す(I) | 本アプリの設定を行います。 導入時の設定に戻します。
ヘルプ(H) ┗目次(I) ┗アプリ情報(A) | ヘルプを表示します。 アプリ情報を表示します。

操作タブ

目次の操作や用語の検索、ファイルへの出力を実行します。

抽出結果一覧

抽出条件に合致する抽出結果のページ一覧を表示します。

ページ内容

選択したページ内容を表示します。

ステータスバー

抽出件数や出力件数を表示します。


目次の操作

目次タブの選択

操作タブの
● 目次
をクリックし、目次タブを表示します。

ページの表示

目次内のページタイトルをクリックし、ページ内容を表示します。

目次ページ行の構成
構成要素 | 説明
しおり 読取モード
 | 未読
[❖] | 読中
[✓] | 既読
[◎] | 他
のいずれかを表示します。
ページタイトル | ページタイトルを表示します。

選択ページ内容の構成
構成要素 | 説明
ページタイトル部
ルート | ルート情報を表示します。
ページタイトル ページタイトルを表示します。
サブタイトルがある場合は、タイトル横に括弧囲みで表示します。
ページ内容部
ページ内容 以下のセクションを並べて表示します。

[説明]　ページ概要を表示します。
[表]　　一覧形式の記載があるページに表示します。
[図]　　図形式の記載があるページに表示します。
[書式]　URL書式などの記載があるページに表示します。
[公式]　公式の記載があるページに表示します。
[証明]　[公式]に対する証明の記載があるページに表示します。
[特徴]　情報機器などの特徴の記載があるページに表示します。
[仕様]　情報機器などの仕様の記載があるページに表示します。
[手順]　処理手順などの特徴の記載があるページに表示します。
[補足]　[説明]に対する補足の記載があるページに表示します。
[参考]　関連する内容の記載があるページに表示します。
[例題]　過去問題の解説などを例題として扱っているページに表示します。
試験出題情報部
略号 試験出題略号
FE | 基本情報技術者
AP | 応用情報技術者
SW | ソフトウェア開発技術者
高共 | 高度共通（午前Ⅰ）
NW | ネットワークスペシャリスト
DB | データベーススペシャリスト
ES | エンベデッドシステムスペシャリスト
SC | 情報処理安全確保支援士
SV | テクニカルエンジニア（情報セキュリティ）
SU | 情報セキュリティアドミニストレータ
のいずれかを表示します。
試験名 | 試験名称を表示します。
出題年 | 試験出題年を和暦で表示します。
季節 試験出題季節
春
秋
―
のいずれかを表示します。
時間帯 試験出題時間帯
午前
午前Ⅰ
午前Ⅱ
午後
午後Ⅰ
午後Ⅱ
科目Ａ
科目Ｂ
のいずれかを表示します。
問番号 | 試験出題問番号を表示します。

なお不在ページタイトルをクリックした場合、（表示できるページ情報がありません）を表示します。

ページグループの表示

目次内のグループタイトルをクリックし、ページグループ内容を表示します。

ページグループの展開と折畳

目次のグループタイトルを選択した状態で
● 表示 > 目次の展開
を選択するか、又は
● グループタイトルを右クリック > 目次の展開
を選択して、ページグループを展開します。

目次のグループタイトルを選択した状態で
● 表示 > 目次の折畳
を選択するか、又は
● グループタイトルを右クリック > 目次の折畳
を選択して、ページグループを折り畳みます。

読取モードの更新

本アプリを複数起動した場合、一方の画面でしおりの設定を行っても
もう一方の画面では、しおりの状態を即反映しません。

この場合、メニューバーの
● 表示 > 最新の情報に更新
をクリックすることで、当画面のしおり状態を更新します。


抽出条件の検索

検索タブの選択

操作タブの
● 検索
をクリックし、抽出条件指定タブを表示します。

抽出条件の指定

以下の抽出条件を指定します。

入力項目 | 桁数 | 説明
以下の文字列を含むページ抽出
検索文字列 (4,096文字まで) | 4096 | 検索する文字列を指定する。 単語間に空白を入れると『OR』検索となる。 ※カタカナは原則全角で入力する。
空白をAND条件とする | - | 複数文字列を『AND』検索とする。
大／小文字を区別する | - | 複数文字列中の半角英文字の大小を区別する。
タイトルのみ比較する | - | タイトルのみを検索対象とする。
読取モードのページ抽出 ※複数指定した場合は『OR』検索
未読 | - | 未読ページを抽出する。
読中 | - | 読中ページを抽出する。
既読 | - | 既読ページを抽出する。
他 | - | 他ページを抽出する。 ※多目的に使用可。
公式を記述したページ抽出
公式記述ページ | - | [公式]を記述しているページを抽出する。
試験に出題されたページ抽出 ※複数指定した場合は『OR』検索
FE | - | 『FE』に出題されたページを抽出する。
AP | - | 『AP』に出題されたページを抽出する。
高共 | - | 『高度共通』に出題されたページを抽出する。
NW | - | 『NW』に出題されたページを抽出する。
DB | - | 『DB』に出題されたページを抽出する。
ES | - | 『ES』に出題されたページを抽出する。
SC | - | 『SC』に出題されたページを抽出する。
出題年 | 4 | 出題年で絞り込む。
出題季節 | 1 | 出題季節で絞り込む。
出題時間帯 出題科目 | 3 | 出題時間帯（出題科目）で絞り込む。
出題問番号 | 2 | 出題問番号で絞り込む。
試験未出題ページ抽出 | - | いずれの試験にも出題されてないページを抽出する。
※抽出分類跨ぎの複数条件指定は『AND』検索となります。

※出題年の西暦・和暦早見表
西暦年 | 和暦年 | 西暦年 | 和暦年 | 西暦年 | 和暦年
2004 | 平成16年 | 2012 | 平成24年 | 2019 | 令和元年
2005 | 平成17年 | 2013 | 平成25年 | 2020 | 令和02年
2006 | 平成18年 | 2014 | 平成26年 | 2021 | 令和03年
2007 | 平成19年 | 2015 | 平成27年 | 2022 | 令和04年
2008 | 平成20年 | 2016 | 平成28年 | 2023 | 令和05年
2009 | 平成21年 | 2017 | 平成29年 | 2024 | 令和06年
2010 | 平成22年 | 2018 | 平成30年 | 2025 | 令和07年
2011 | 平成23年 | 2019 | 平成31年 | 2026 |

抽出の開始

抽出開始ボタンをクリックすると、
条件に該当するページを抽出結果のページ一覧に表示します。

抽出処理の終了時に、抽出結果の一覧と件数を表示します。
抽出条件を指定せずに抽出開始ボタンをクリックすると、抽出結果は0件となります。

抽出結果一覧の行クリックで、ページ内容を表示します。

抽出条件のクリア

入力した抽出条件を全クリアします。


データの出力

出力タブの選択

操作タブの
● 出力
をクリックし、出力条件指定タブを表示します。

出力条件の指定

以下の出力条件を指定します。

入力項目 | 桁数 | 説明
出力ファイルパス
出力ファイルパス (1,024文字まで) | 1024 | 出力ファイルパスを入力 、又は選択画面にて指定する。
選択 | -
出力順
目次順 試験別 | - | 出力データを目次順に出力する。 出力データを試験毎の目次順に出力する。
出力範囲
全ページ 抽出結果 | - | 用語データを全ページ出力する。 用語データを抽出件数分、出力する。
出力内容
項目区切り文字 カンマ タブ | - | 出力項目をカンマ区切りで出力する。 出力項目をタブ区切りで出力する。
項目囲み文字 (なし) ’ ” | - | 出力項目を囲み文字なしで出力する。 出力項目にシングルクォートを付加して出力する。 出力項目をダブルクォートで囲んで出力する。
見出しを出力する | - | 見出し行の出力有無を指定する。
出力項目 NO ルート タイトル サブタイトル 読取モード 公式 説明 試験(FE) 試験(AP) 試験(高共) 試験(NW) 試験(DB) 試験(ES) 試験(SC) | - | 出力項目の出力有無と出力順を指定する。

出力の開始

出力開始ボタンをクリックすると、指定ファイルパスに用語データを出力します。

出力処理の終了時に、出力結果件数をステータスバーに表示します。


しおり設定

メニューバーより設定

目次のページ、又はグループを選択した状態で
● ファイル > しおり > （読取モードいずれか）
を選択します。

例えば
『00_基数』ページを『✓既読』に設定すると、以下のように表示します。

目次より設定

目次のページ、又はグループを選択した状態で
● 右クリック > （読取モードいずれか）
を選択します。

ページ内容より設定

ページタイトル、ページ内容、試験情報、又は抽出結果のページ一覧行のいずれかで
● 右クリック > （読取モードいずれか）
を選択します。


設定

設定画面の表示

メニューバーのツール(T)を選択
● 設定(S)
をクリックし、設定画面を表示します。

設定内容の反映

『保存』ボタンをクリックし、設定内容を保存します。

保存した設定内容は、次回起動時も有効となります。

フォントの設定値変更

以下の設定値を変更します。

入力項目 | 桁数 | 説明
目次の文字書式 | - | 目次の文字書式（標準／太字／斜体）を設定する。
目次の文字サイズ | - | 目次の文字サイズ（大／中／小）を設定する。
抽出結果の文字書式 | - | 抽出結果の文字書式（標準／太字／斜体）を設定する。
抽出結果の文字サイズ | - | 抽出結果の文字サイズ（大／中／小）を設定する。
ルートの文字書式 | - | ルートの文字書式（標準／太字／斜体）を設定する。
ルートの文字サイズ | - | ルートの文字サイズ（大／中／小）を設定する。
タイトルの文字書式 | - | タイトルの文字書式（標準／太字／斜体）を設定する。
タイトルの文字サイズ | - | タイトルの文字サイズ（大／中／小）を設定する。
ページ内容の文字書式 | - | ページ内容の文字書式（標準）を設定する。
ページ内容の文字サイズ | - | ページ内容の文字サイズ（大／中／小）を設定する。
試験出題情報の文字書式 | - | 試験出題情報の文字書式（標準）を設定する。
試験出題情報の文字サイズ | - | 試験出題情報の文字サイズ（大／中／小）を設定する。

入力項目 | 桁数 | 説明
抽出条件の文字書式 | - | 抽出条件の文字書式（標準／太字／斜体）を設定する。
抽出条件の文字サイズ | - | 抽出条件の文字サイズ（大／中／小）を設定する。
抽出開始ボタンの文字書式 | - | 抽出開始ボタンの文字書式（標準／太字／斜体）を設定する。
抽出開始ボタンの文字サイズ | - | 抽出開始ボタンの文字サイズ（大／中／小）を設定する。

入力項目 | 桁数 | 説明
出力条件の文字書式 | - | 出力条件の文字書式（標準／太字／斜体）を設定する。
出力条件の文字サイズ | - | 出力条件の文字サイズ（大／中／小）を設定する。
出力開始ボタンの文字書式 | - | 出力開始ボタンの文字書式（標準／太字／斜体）を設定する。
出力開始ボタンの文字サイズ | - | 出力開始ボタンの文字サイズ（大／中／小）を設定する。

試験出題情報の設定値変更

以下の設定値を変更します。

入力項目 | 桁数 | 説明
FE行を表示する | - | 試験出題一覧FE行の表示有無を設定する。
AP行を表示する | - | 試験出題一覧AP行の表示有無を設定する。
高共行を表示する | - | 試験出題一覧高度共通行の表示有無を設定する。
NW行を表示する | - | 試験出題一覧NW行の表示有無を設定する。
DB行を表示する | - | 試験出題一覧DB行の表示有無を設定する。
ES行を表示する | - | 試験出題一覧ES行の表示有無を設定する。
SC行を表示する | - | 試験出題一覧SC行の表示有無を設定する。

終了時オプションの設定値変更

以下の設定値を変更します。

入力項目 | 桁数 | 説明
画面サイズ情報を保存する | - | アプリ終了時の画面サイズ情報保存有無を設定する。
抽出条件を保存する | - | アプリ終了時の抽出条件保存有無を設定する。

導入時の設定に戻す

メニューバーのツール(T)を選択
● 導入時の設定に戻す(I)
をクリックし、変更した値を導入時の設定に戻します。

設定を初めからやり直したい場合に選択し、実行後にアプリを再起動してください。


ヘルプ

アプリメニューのヘルプ表示
メニューバーのヘルプ(H)を選択
● 目次(I)
をクリックし、ヘルプ画面を表示します。

プログラムメニューのヘルプ表示
プログラムメニューのIT頭語集を選択
● IT頭語集 ヘルプ
をクリックし、ヘルプ画面を表示します。

アプリメニューのヘルプと同じ内容を表示します。


アプリ情報

画面の表示

メニューバーのヘルプ(H)を選択
● アプリ情報(A)
をクリックし、アプリ情報画面を表示します。

当画面では、以下の内容を確認できます。
● アプリ名
● アプリバージョン．データバージョン
● 著作者名
● 著作者URL
● ライセンシー

『著作者URL』のクリックで、著作者ホームページを表示します。


閉じる

メニューによる終了

メニューバーのファイル(F)を選択
● 閉じる(C)
をクリックし、アプリを終了します。

×ボタンによる終了

メイン画面タイトルバーの
● ×ボタン
をクリックし、アプリを終了します。