遠隔キーボード ヘルプ
本アプリは、通信回線を介してパソコン等のキーボード操作を行う
常駐型のキーボード遠隔操作デーモンです。

本アプリを常駐した端末のキーボードを、クライアントアプリより操作できます。

クライアントアプリとして、
●ＰＣキーボードアプリよりキー操作
●ＰＣテンキーアプリよりキー操作
●ＱＲコード転送アプリよりテキスト貼り付け操作
●専用のクライアントキーボードよりキー操作
などを用意しています。

© 2024 IT-brains Co.,Ltd.


お使いになる前に
本アプリご使用の前に必ずお読み下さい。
はじめに
使用目的
アンインストール


はじめに

アプリケーション概要
本アプリは、通信回線を介してパソコン等のキーボード操作を行う
常駐型のキーボード遠隔操作デーモンです。

本アプリを常駐した端末のキーボードを、クライアントアプリより操作できます。

クライアントアプリとして、
●ＰＣキーボードアプリよりキー操作
●ＰＣテンキーアプリよりキー操作
●ＱＲコード転送アプリよりテキスト貼り付け操作
●専用のクライアントキーボードよりキー操作
などを用意しています。

ご使用にあたり、はじめに注意事項をお読みください。

動作環境

基本ソフトウェア
Windows 7 日本語版(SP1) 以降
最小稼動メモリ | 4 MB以上
ハードディスク | 20 MB以上の空き容量

使用にあたっての注意事項
● | Wi-Fiの ・Wi-Fi Alliance ・Wi-Fi ロゴ ・WPA及びWPA2、WPA3 は、Wi-Fi Allianceの商標、又は登録商標です。
● | Bluetooth® のワードマーク、及びロゴは、Bluetooth SIG, Inc.が所有する登録商標です。
● | 本アプリの一部、又は全部を無断で複製・転載することは禁じられています。
● | 本アプリの使用に関して運用した結果の影響については責任を負いかねます。 あらかじめご了承ください。
● | 本アプリをサイバー犯罪など、不正に利用することを固く禁じます。
● | 本アプリをインターネット経由で使用する場合、VPN接続などによる通信を推奨します。 （本アプリに対する不正接続防止のため）
● | 本アプリやヘルプについて、万全を期して製作しておりますが、万一 ・不正動作（不具合） ・不正な記載や誤り ・記載漏れ など、お気づきの点がありましたら製作元までご一報ください。


使用目的

ログ記録について
1) 本アプリの動作環境設定で
✓通信ログを記録する
✓キーログを記録する
に設定すると、ログ格納フォルダにログを出力します。
使用頻度によっては大量のログを出力し、ログファイルを蓄積していきます。

本アプリではログの削除を行いませんので、
一定期間を経過したログの削除対応等をお願いします。

なお『通信ログ』については、ログ記録レベルを
●警告
に設定すると、『エラー』『警告』の内容のみ出力するようになりますので、
ログの出力量を大幅に抑えることができます。

2) | 通信ログをCSV形式に変換出力することができます。 プログラムメニューの『通信ログ変換』をクリックし、 通信ログ変換画面を起動します。
 | 『出力フォルダ』『タイトルを出力する』を入力してから、 『出力』ボタンをクリックすると、出力フォルダに『CSV形式ファイル』を作成します。

活用例
1) 『ＰＣテンキー』を使用して電卓を操作します。

●遠隔キーボードの動作環境設定

設定項目 | 設定値
操作許可識別子 | ItbKeyDaemon
キー押下を許可する | ✓
有線/無線LAN通信を有効にする | ✓
IPバージョン | ◎IPv4
ポート番号 | 50020

●ＰＣテンキーの通信設定

設定項目 | 設定値
操作許可識別子 | ItbKeyDaemon
Wifi/モバイル通信を使用する | ✓
ホスト名 | キー操作を行うPCのホスト名を指定
ポート番号 | 50020

●ＰＣテンキーを入力し、ＰＣの電卓を操作する
  ＰＣテンキーの入力に合わせて、電卓が反応します。


アンインストール

手順

以下の手順で、本アプリのアンインストールを行います。

1) | スタートメニューの『設定』をクリックします。
2) | 『アプリ』をクリックします。
3) | 『遠隔キーボード』を選択し、アンインストールをクリックします。 手順に従って操作してください。
※ 導入後に作成したフォルダ／ファイルがある場合、この操作ではフォルダ／ファイルを削除しません。
この場合、フォルダ／ファイルは手動で削除してください。


操作の説明
アプリの起動と終了
通信方法の切り替え
端末接続の許可と禁止
動作環境の設定
アプリ情報の表示


アプリの起動と終了

遠隔キーボードの開始

本アプリはパソコンの起動時に自動的に起動し、キーボード操作に待機します。

本アプリの起動時に
●Windows セキュリティの重要な警告
が表示された場合、『アクセスを許可する』を選択してください。

タスクトレイの遠隔キーボードを終了したなど、キーボード操作待機が終了状態である場合は、
プログラムメニューの『遠隔キーボード』をクリックし、キーボード操作待機を再開します。

遠隔キーボードの終了

タスクトレイの『遠隔キーボードアイコン』を右クリックし、メニューを表示します。
メニューの終了をクリックすると、本アプリを終了します。

終了操作は『遠隔キーボードアイコン』の左クリックでも同様に行えます。
メニューの終了をクリックすると、本アプリを終了します。


通信方法の切り替え

有線/無線LANによる通信

有線/無線LAN通信によるキー操作に待機します。
本アプリ使用前に、ネットワークが利用可能であることを確認してください。

ルータなどを介して、インターネット経由での通信や、
ローカルエリアでの通信を行う場合などに選択します。

設定ボタン押下後、即切り替わります。

Bluetoothによる通信

Bluetooth通信によるキー操作に待機します。
本アプリ使用前に、Bluetoothが利用可能であることを確認してください。

Bluetoothの電波が届く範囲でかつ、端末間で通信を完結したい場合に選択します。
通信に先立ち、事前に対象端末とのペアリング設定が必要となります。

設定ボタン押下後、即切り替わります。


端末接続の許可と禁止

端末接続の禁止

本アプリは『遠隔キーボード』を終了→起動しなおすことなく、
端末接続の禁止→許可と切り替えて、リセットできます。

本アプリの起動時に、端末の接続を許可した状態で開始しますが、
電波障害などにより通信が中断された場合など、
キーボード操作の待機状態に遷移しないことがあります。
この場合、端末より接続を試みても失敗します。
このような状態に陥った場合、端末接続を一旦禁止に切り替えてください。

タスクトレイの『遠隔キーボードアイコン』を右クリックし、メニューを表示します。

メニューの『端末接続禁止』をクリックし、実行確認を表示します。

実行確認の『はい』をクリックし、端末の接続を禁止に切り替えます。

端末接続の許可

接続を禁止に切り替えた端末接続を、許可に切り替えます。

タスクトレイの『遠隔キーボードアイコン』を右クリックし、メニューを表示します。

メニューの『端末接続許可』をクリックし、実行確認を表示します。

実行確認の『はい』をクリックし、端末の接続を許可に切り替えます。

尚、本処理で端末接続のリセットを行っても、
●本処理の実行後に実行結果メッセージが表示されない場合
●端末側で接続に失敗する場合
は、本アプリの終了→起動を行ってください。


動作環境の設定

遠隔キーボード設定画面の表示

タスクトレイの『遠隔キーボードアイコン』を右クリックし、メニューを表示します。

メニューの『設定』をクリックし、設定画面を表示します。

通信の共通設定

通信共通の属性に関する設定を行います。

入力項目 | 桁数 | 説明
操作許可識別子 （英数20文字まで） | 20 | 操作要求を許可する識別子を指定する。 ※端末接続時の認証に使用します。 未入力の場合、接続を許可しません。
開始失敗時リトライ待機時間 （1～120秒） | 3 | パソコン起動時、接続待機に失敗することがある場合に、 開始失敗後の再接続に待機する時間を指定する。
開始失敗時リトライ回数 （0～5回） | 1 | パソコン起動時、接続待機に失敗することがある場合に、 リトライ待機時間おきに再接続を試みる回数を指定する。 ※0に設定すると再接続を行いません。
強制中断待機時間 （0～1440分） | 4 | 接続後の受信に待機する時間を指定する。 ※設定時間を経過しても端末の要求を受信できない場合、 通信処理を強制的にリセットします。 0に設定すると強制中断を行いません。
キー押下を許可する | - | キー押下操作を許可する。 ※チェックを解除すると、キー押下処理を実行しません。
電源OFF/再起動を許可する | - | 電源OFF／再起動操作を許可する。 ※チェックを解除すると、 電源OFF／再起動処理を実行しません。
ログ格納フォルダ | 1024 | ログインユーザーが書き込み可能な ログファイルを格納するフォルダを指定する。
選択ボタン | - | ログ格納フォルダ選択ダイアログを表示する。
通信ログを記録する | - | 通信ログを記録する場合に指定する。
ログ記録レベル | - | 通信ログの記録レベルを指定する。 記録なし タイトル 接続毎の区切りを記録する。 エラー 発生したエラーコードを記録する。 警告 受信強制終了警告を記録する。 概要 接続／切断／送受信内容を記録する。 詳細 キー操作内容を記録する。 全記録
キーログを記録する | - | キーログを記録する場合に指定する。

通信方法の設定

通信方法の選択と、通信属性に関する設定を行います。

入力項目 | 桁数 | 説明
有線/無線LAN通信を有効にする | - | LAN通信を使用する場合に指定する。
IPバージョン ●IPv4 ●IPv6 | - | ソケット通信のIPバージョンを選択する。 IP version 4（のみ）で接続待機する。 IP version 6（のみ）で接続待機する。
ポート番号 （49512～65535） | 5 | ソケット通信の受信ポート番号を指定する。 ※接続端末も同じ値を設定してください。
応答待機時間 （0～60秒） | 2 | ソケット通信の送受信に待機する時間を指定する。
Bluetooth通信を有効にする | - | Bluetooth通信を使用する場合に指定する。
応答待機時間 （0～60秒） | 2 | Bluetooth通信の送受信に待機する時間を指定する。

入力内容の保存

入力内容を保存します。

入力項目 | 桁数 | 説明
設定ボタン | - | 入力内容を設定ファイルに保存し、画面を閉じる。
キャンセルボタン | - | 編集をキャンセルし、画面を閉じる。


アプリ情報の表示

遠隔キーボードのアプリ情報

タスクトレイの『遠隔キーボードアイコン』を右クリックし、メニューを表示します。

メニューの『アプリ情報』をクリックし、アプリ情報画面を表示します。

当画面では、以下の内容を確認できます。
●アプリ名とバージョン
●著作者名
●著作者URL

『著作者URL』のクリックで、著作者ホームページを表示します。

ホスト情報
●通信モード
●デバイス名
●ホスト名
●ポート番号

『ホスト情報』は、本アプリが動作している端末の情報です。
クライアントアプリの接続情報を設定する際に、ご利用ください。