遠隔キーボードクライアント ヘルプ
本アプリは、『遠隔キーボード』を導入した端末の
キーボードを遠隔操作するためのクライアントアプリです。

本アプリを使用してキー操作を行うことにより、
『遠隔キーボード』の動作検証などを実践できます。

© 2023 IT-brains Co.,Ltd.


お使いになる前に
本アプリご使用の前に必ずお読み下さい。
はじめに
使用目的
アンインストール


はじめに

アプリケーション概要
本アプリは、『遠隔キーボード』を導入した端末の
キーボードを遠隔操作するためのクライアントアプリです。

本アプリを使用してキー操作を行うことにより、
『遠隔キーボード』の動作検証などを実践できます。

ご使用にあたり、はじめに注意事項をお読みください。

動作環境

基本ソフトウェア
Windows 7 日本語版(SP1) 以降
最小稼動メモリ | 3 MB以上
ハードディスク | 5 MB以上の空き容量

使用にあたっての注意事項
● | Wi-Fiの ・Wi-Fi Alliance ・Wi-Fi ロゴ ・WPA及びWPA2、WPA3 は、Wi-Fi Allianceの商標、又は登録商標です。
● | Bluetooth® のワードマーク、及びロゴは、Bluetooth SIG, Inc.が所有する登録商標です。
● | 本アプリの一部、又は全部を無断で複製・転載することは禁じられています。
● | 本アプリの使用に関して運用した結果の影響については責任を負いかねます。 あらかじめご了承ください。
● | 本アプリをサイバー犯罪など、不正に利用することを固く禁じます。
● | 本アプリをインターネット経由で使用する場合、VPN接続などによる通信を推奨します。 （本アプリに対する不正接続防止のため）
● | 本アプリやヘルプについて、万全を期して製作しておりますが、万一 ・不正動作（不具合） ・不正な記載や誤り ・記載漏れ など、お気づきの点がありましたら製作元までご一報ください。


使用目的

ログ記録について
1) 本アプリの共通設定で
✓ログを記録する
に設定すると、ログ格納フォルダにログを出力します。
使用頻度によっては大量のログを出力し、ログファイルを蓄積していきます。

本アプリではログの削除を行いませんので、
一定期間を経過したログの削除対応等をお願いします。

なお、ログ記録レベルを
●警告
に設定すると、『エラー』『警告』の内容のみ出力するようになりますので、
ログの出力量を大幅に抑えることができます。

活用例
1) 『遠隔キーボード』導入端末のキーボードを操作する

●遠隔キーボードの動作環境設定

設定項目 | 設定値
操作許可識別子 | ItbKeyDaemon
キー押下を許可する | ✓
電源OFF/再起動を許可する | ✓ ※[再起動][電源OFF]を使用する場合
通信ログを記録する | ✓ ※キー押下履歴を確認する場合
通信ログレベル | 詳細 ※キー押下実績を確認する場合
有線/無線LAN通信を有効にする | ✓
IPバージョン | ◎IPv4
ポート番号 | 50020

●遠隔キーボードクライアントの通信設定

設定項目 | 設定値
IPバージョン | ◎IPv4
ホスト名 | 遠隔キーボードを導入したホスト名を指定
ポート番号 | 50020
操作許可識別子 | ItbKeyDaemon

上記設定を保存した上で、遠隔キーボードクライアントのキーを押下すると、
『遠隔キーボード』を導入した端末に、押下キーを送信します。


アンインストール

手順

以下の手順で、本アプリのアンインストールを行います。

1) | スタートメニューの『設定』をクリックします。
2) | 『アプリ』をクリックします。
3) | 『遠隔キーボードクライアント』を選択し、アンインストールをクリックします。 手順に従って操作してください。
※ 導入後に作成したフォルダ／ファイルがある場合、この操作ではフォルダ／ファイルを削除しません。
この場合、フォルダ／ファイルは手動で削除してください。


操作の説明
アプリの起動と終了
接続先の登録
キー押下の操作方法
動作環境の共通設定
アプリ情報の表示


アプリの起動と終了

遠隔キーボードクライアントの起動

プログラムメニューの『遠隔キーボードクライアント』をクリックします。

遠隔キーボードクライアントを起動します。

遠隔キーボードクライアントの終了

タイトルの『アイコン』を左クリック又は右クリックし、メニューを表示します。

メニューの『閉じる』をクリックし、終了確認メッセージを表示します。

終了確認メッセージの『はい』をクリックすると、本アプリを終了します。


接続先の登録

通信設定画面の表示

接続先『遠隔キーボード』の通信情報を登録します。

新規に追加（最大20登録可）する場合は
●（接続先を追加する）
を、登録済みの内容を編集する場合は
●対象ホスト名
を選択します。

『編集』ボタンをクリックし、通信設定画面を表示します。

有線/無線LAN通信設定

有線/無線LAN通信情報を設定します。

入力項目 | 桁数 | 説明
IPバージョン ●IPv4 ●IPv6 | - | ソケット通信のIPバージョンを選択する。 IP version 4（のみ）で接続待機する。 IP version 6（のみ）で接続待機する。
ホスト名 | 1024 | ソケット通信の接続先ホスト名 ●IPアドレス ●コンピュータ名 ●ドメイン名 のいずれかを指定する。
ポート番号 （49512～65535） | 5 | ソケット通信の送信ポート番号を指定する。 ※接続先も同じ値を設定してください。
接続待機時間 （0～60秒） | 2 | ソケット通信の接続に待機する時間を指定する。
応答待機時間 （0～60秒） | 2 | ソケット通信の送受信に待機する時間を指定する。
操作許可識別子 （英数20文字まで） | 20 | 操作要求を許可する識別子を指定する。 ※端末接続時の認証に使用します。

入力内容の保存

入力内容を保存します。

入力項目 | 桁数 | 説明
設定ボタン | - | 入力内容を設定ファイルに保存し、画面を閉じる。
キャンセルボタン | - | 編集をキャンセルし、画面を閉じる。


キー押下の操作方法

画面キーボードの役割

接続先『遠隔キーボード』に接続してより、切断するまでの間に
●画面キーボード
又は
●物理キーボード
によりキー操作を行います。

●特殊操作のキー

操作キー | 説明
端末接続 端末切断 | 接続先遠隔キーボードに接続する。 接続先遠隔キーボードを切断する。
CapsLock | 初回押下、又はクリックでロック、 再度押下、又はクリックでロック解除する。
SHIFT | 初回押下、又はクリックで押下、 再度押下、又はクリックで押下解除する。
CTRL | 初回押下、又はクリックで押下、 再度押下、又はクリックで押下解除する。
ALT | 初回押下、又はクリックで押下、 再度押下、又はクリックで押下解除する。
WIN | 初回押下、又はクリックで押下、 再度押下、又はクリックで押下実行する。 ※ただし他の修飾キーを押下している場合、 初回押下、又はクリックで押下実行する。
再起動 | 実行確認後、接続先端末を再起動する。
電源OFF | 実行確認後、接続先端末の電源をシャットダウンする。
キー状態更新 | NumLockとCapsLockの状態を手動で更新する。
メッセージ | 操作結果を表示する。 ●正常メッセージ ・（押下キー） ・接続先にシャットダウンを要求しました。 ・接続先に再起動を要求しました。 ●異常メッセージ ・接続先との通信接続に失敗しました。 →遠隔キーボードの起動有無とホスト名を確認 ・接続先との通信切断に失敗しました。 →本アプリを再起動 ・操作許可の認証に失敗しました。 →操作許可識別子が正しいか確認 ・キー状態の取得に失敗しました。 →接続先との通信を切断し、接続しなおす ・キー押下操作を拒否されました。 →『✓キー押下を許可する』に設定しているか確認 ・電源切断操作を拒否されました。 →『✓電源切断を許可する』に設定しているか確認

画面キーボードのクリックによるキー送信

画面キーボードをクリックで押下して、キーを送信します。

画面キーボードには、キーが割り当てられていない
●端末切断（入）
●キー状態更新
●再起動
●電源OFF
ボタンが存在します。

これらボタンは、マウスクリックによりキー送信を行ってください。

物理キーボードのキー押下によるキー送信

物理キーボードを押下して、キーを送信します。

自端末の『遠隔キーボード』と通信する場合、
本アプリよりキー送信すると、本アプリで送信キーを受信することになり、
キー送信を繰り返し実行することがあります。

自端末の『遠隔キーボード』と通信する場合は、共通設定の
✓物理キーボードの使用を許可する
を外すようにしてください。


動作環境の共通設定

共通設定画面の表示

タイトルの『アイコン』を左クリック又は右クリックし、メニューを表示します。

メニューの『共通設定』をクリックし、共通設定画面を表示します。

通信の共通設定

通信共通の属性に関する設定を行います。

入力項目 | 桁数 | 説明
強制中断待機時間 （0～1440分） | 4 | 接続後の受信に待機する時間を指定する。 ※設定時間を経過しても端末の要求を受信できない場合、 通信処理を強制的にリセットします。 0に設定すると強制中断を行いません。
ログ格納フォルダ | 1024 | ログインユーザーが書き込み可能な ログファイルを格納するフォルダを指定する。
選択ボタン | - | ログ格納フォルダ選択ダイアログを表示する。
ログを記録する | - | ログを記録する場合に指定する。
ログ記録レベル | - | 通信ログの記録レベルを指定する。 記録なし タイトル 接続毎の区切りを記録する。 エラー 発生したエラーコードを記録する。 警告 受信強制終了警告を記録する。 概要 接続／切断／送受信内容を記録する。 詳細 キー操作内容を記録する。 全記録

キーボードの設定

キーボード属性に関する設定を行います。

入力項目 | 桁数 | 説明
物理キーボードの使用を許可する | - | 本アプリを導入した端末の物理キーボードで キー押下による送信を許可する場合に指定する。
キー押下時に音を出力する | - | キー押下の都度、音を出力する場合に指定する。

入力内容の保存

入力内容を保存します。

入力項目 | 桁数 | 説明
設定ボタン | - | 入力内容を設定ファイルに保存し、画面を閉じる。
キャンセルボタン | - | 編集をキャンセルし、画面を閉じる。


アプリ情報の表示

遠隔キーボードクライアントのアプリ情報

タイトルの『アイコン』を左クリック又は右クリックし、メニューを表示します。

メニューの『アプリ情報』をクリックし、アプリ情報画面を表示します。

当画面では、以下の内容を確認できます。
●アプリ名とバージョン
●著作者名
●著作者URL

『著作者URL』のクリックで、著作者ホームページを表示します。