ＱＲ読取転送 ヘルプ
本アプリは、バーコードをスマートフォンで読み取り、
読み取ったデータをＰＣに送信する、バーコード読取転送ツールです。

送信されたデータは、当社製品
● 遠隔キーボード
を使用し、ＰＣのアクティブコントロールに貼り付けます。

バーコードの転送ツールとして、ご活用ください。

また、本アプリのご使用にあたり、
● お使いになる前に
● 操作の説明
の方を必ず一読下さいますよう、お願い致します。

© 2025 IT-brains Co.,Ltd.


お使いになる前に
本アプリご使用の前に必ず一読下さい。
はじめに
使用目的
アンインストール


はじめに

アプリケーション概要
本アプリは、バーコードをスマートフォンで読み取り、
読み取ったデータをＰＣに送信する、バーコード読取転送ツールです。

送信されたデータは、当社製品
● 遠隔キーボード
を使用し、ＰＣのアクティブコントロールに貼り付けます。

バーコードの転送ツールとして、ご活用ください。

動作環境

プラットフォーム
Android 8.0.0 以降
（APIレベル26 以降）
必要最小メモリ | 18.70 MB以上
アプリ | 9.24 MB以上
データ | 8.95 MB以上

使用にあたっての注意事項
● | Wi-Fiの ・Wi-Fi Alliance ・Wi-Fi ロゴ ・WPA及びWPA2、WPA3 は Wi-Fi Allianceの商標、又は登録商標です。
● | Bluetooth® のワードマーク、及びロゴは、 Bluetooth SIG, Inc.が所有する登録商標です。
● | 本アプリの一部、又は全部を無断で複製・転載することは禁じられています。
● | 本アプリの内容に関して運用した結果の影響については責任を負いかねます。 あらかじめご了承ください。
● | 本アプリをサイバー犯罪など、不正に利用することを固く禁じます。
● | 本アプリで読取転送可能な ・バーコード を、転送先パソコンに導入する 遠隔キーボードで押下可能なキーコード 0～9 A～Z（a～z） :*;+,<-=.>/?@`[{\|]}^~_ で構成されているデータに限定します。 ＰＣキーボードで受理できない漢字コードなどで構成されたＱＲは扱えませんので ご注意ください。
● | 本アプリのご利用にあたり ・カメラ ・ストレージ の使用許可が必要となります。 初回起動時に許可確認ダイアログを表示しますので、[許可]を選択してください。
● | 本アプリは ・モバイルネットワーク ・Wi-Fi ・Bluetooth などの通信回線を利用します。 モバイルネットワーク使用時のデータ通信量等にご注意ください。
● | 本アプリは、無線回線を使用して通信を 行います。 電波状況の悪い場所で使用すると、通信回線の切断が発生してしまいますので、 電波状況の良い場所にてご使用ください。
● | 本アプリは、カメラ撮影部に ・Android System WebView を利用しております。 カメラが正常に動作しない場合、 WebView の設定にて『キャッシュの削除』を実行頂くことで、改善する場合があります。
● | 本アプリやヘルプについて、 万全を期して製作しておりますが、万一 ・不正動作（不具合） ・不正な記載や誤り ・記載漏れ など、お気づきの点がありましたら製作元までご一報ください。


使用目的

遠隔キーボードの導入

本アプリのご使用に先立ち、バーコード転送先のパソコン／サーバに
● 遠隔キーボード ver 1.2.2
以降を導入頂く必要があります。

遠隔キーボードのインストーラを入手→導入→起動してから、
以下の設定を確認してください。

● 遠隔キーボード ver 2.0.0 以降

設定項目 | 設定値
操作許可識別子 | （任意の英数文字列）
キー押下を許可する |

・Wi-Fi/モバイル通信を利用する場合
設定項目 | 設定値
有線/無線LAN通信を有効にする |
IPバージョン | ●IPv4
ポート番号 | 50020

・Bluetooth通信を利用する場合
設定項目 | 設定値
Bluetooth通信を有効にする |

注1) | 設定値は即座に反映されます。（再起動不要）
注2) | ポート番号は必要に応じて変更してください。
注3) | 通信方法は ・有線/無線LAN通信 ・Bluetooth通信 のいずれか一方を選択してください。
注4) | 通信ログを記録する キーログを記録する に設定した場合、スマートフォンの接続より切断までのキーロガーを保存します。 ログ出力が不要である場合、設定をオフにしてください。

● 遠隔キーボード ver 1.2.2 以前

設定項目 | 設定値
IPバージョン | ●IPv4
ポート番号 | 50011
操作許可識別子 | （任意の英数文字列）
電文終端に改行コードを付加する |
キー押下を実行する |
Num／Funcキーを無効にし、英小文字を許可する |

注1) | 設定値は即座に反映されます。（再起動不要）
注2) | ポート番号は必要に応じて変更してください。

カメラ・ストレージの使用許可

本アプリの初回起動時に、
● カメラ
● ストレージ（確認不要の場合あり）
の撮影・アクセス許可確認ダイアログを順次表示します。

確認項目 | 使用目的
カメラ | バーコードを読み取ります。
ストレージ | 未送信情報を保存します。

撮影許可確認ダイアログで
● 許可しない
を選択した場合、本アプリは強制終了します。
● 許可
を選択した場合、本アプリは再起動し、再起動後に使用可能となります。

バーコード読取転送の設定

本アプリの初回起動後に
● OverFlowメニューの動作設定
で以下の設定を行ってください。

設定項目 | 設定値
カメラ幅・高さ | カメラのサイズを指定
操作許可識別子 | PCキーボードの操作許可識別子を指定

・Wi-Fi/モバイル通信を利用する場合
設定項目 | 設定値
Wi-Fi/モバイル通信を使用する |
ホスト名 | PCキーボードのIPアドレスを指定
ポート番号 | PCキーボードのポート番号を指定

・Bluetooth通信を利用する場合
設定項目 | 設定値
Bluetooth通信を使用する |
デバイス名 | PCキーボードのデバイスを選択

注1) | 設定値は即座に反映されます。（再起動不要）
注2) | Wi-Fi接続を利用する場合、 有効なSSIDを端末に事前登録する必要があります。
注3) | Bluetooth通信を利用する場合、 ペア設定(ペアリング)を事前に実施する必要があります。

活用例

パソコンで読取コンテンツを表示する

1) パソコンでブラウザを起動し、アドレス指定部にカーソルを移動します。

2) バーコード読取転送の動作設定で
データ終端に改行を付加して送信する
に設定した状態で、URLが埋め込まれたバーコードを読み取り送信します。

3) バーコードに埋め込まれたURLのコンテンツが表示されます。


アンインストール

手順
以下の手順で、本アプリのアンインストールを行います。

1) | Android端末の「設定」画面を開き、「アプリと通知」をタップします。
2) | 「アプリ情報」をタップします。
3) | アプリ一覧の「ＱＲ読取転送」をタップします。
4) | 「アンインストール」をタップし、「OK」をタップします。


操作の説明

画面の構成
本アプリを起動し、操作画面を表示します。

操作の説明
画面の構成
バーコードの読み取り
バーコードの送信
未送信一覧
動作設定
ヘルプ
アプリ情報
閉じる


画面の構成

ActionBar

接続先と各種メニューを表示します。

コントロール | 説明
192.168.0.1 | 動作設定で選択中の接続先ホスト/デバイス名表示
 | ＰＣに読取内容送信ボタン
 | Overflowメニュー

撮影切替・読取内容表示部

撮影の開始と停止を切り替え、撮影したバーコードの読み取り内容を表示します。

コントロール | 説明
 | 通信方法アイコン 読取開始・停止切替ボタン
ABCDE… | 読取データ表示パネル

バーコード読取部

バーコードを撮影し、読取内容を取得します。

コントロール | 説明
📹 | バーコード撮影カメラ

※バーコード撮影カメラのサイズについて
動作設定の
● カメラ幅
● カメラ高さ
を、手動で調整してください。

カメラ幅・高さを自動調整する
に設定すると、アプリ起動時に最適なサイズに自動調整します。

ご使用の端末に合わせて、手動／自動調整を選択してください。


バーコードの読み取り

撮影の開始と停止

本アプリは、読取開始の状態で起動します。

読取ボタンの背景色により、開始・停止の状態を判断します。

読取ボタン | 説明
 | 未送信データのない、読取可能な状態です。 ボタンタップで読取停止状態に遷移します。
 | 未送信データのある、読取可能な状態です。 ボタンタップで読取停止状態に遷移します。
 | 読取を停止している状態です。 ボタンタップで読取可能状態に遷移します。

注1) | 読取開始・停止操作を手動で行いますが、 ● バーコードデータ送信後 ● 未送信一覧画面遷移時 ● 動作設定画面遷移時 は、開始・停止を自動で切り替えます。
注2) | 撮影開始に切り替わる際に、少々時間がかかることがあります。 この場合、画面操作を行わずに撮影開始までお待ちください。 読取ボタンをタップしてから ● 読取押下許可（秒後） を経過するまで、次の読取ボタンタップを受け付けません。

バーコードデータの取得

撮影を開始してバーコードを読み取ります。

読取開始直後は、読取データ表示パネルに
● ＜ＱＲを読み取ってください＞
を表示しますので、この状態で撮影枠にバーコードを撮影してください。

バーコードを認識すると撮影を自動停止し、
画像を赤枠で囲んた静止画像に切り替わり、
● 読取データ表示パネル
に読取内容を表示します。

読取内容を全表示したい場合は、読取データ表示パネルをロングタップして
● 読取内容ダイアログ
を表示します。

動作設定で、
バーコード読取後、自動的に送信する
と設定している場合、送信ボタンをタップし、送信を実行します。

送信ボタンをタップせずに読取開始した場合、読み取ったバーコードは破棄します。


バーコードの送信

ネットワーク状態の表示

Wi-Fi/モバイル通信を使用する
を選択している場合

ネットワーク状態変更の都度、
読取開始。停止ボタンに以下いずれかのアイコンを表示します。

通信方法 | 説明
 | Wi-Fi通信で送信可
 | モバイル通信で送信可
 | 送信不可（通信無効）

Bluetooth通信を使用する
を選択している場合

Bluetooth状態変更の都度、
読取開始。停止ボタンに以下いずれかのアイコンを表示します。

通信方法 | 説明
 | Bluetooth通信で送信可
 | 送信不可（通信無効）

読取データの編集と情報付加

動作設定の内容により、送信前に以下の編集を実施します。

英大文字に変換して送信する
送信するデータ中の『英小文字』を『英大文字』に変換して送信します。

英小文字に変換して送信する
送信するデータ中の『英大文字』を『英小文字』に変換して送信します。

データ終端に改行を付加して送信する
送信するデータ末尾に『改行コード』を付加して送信します。

読取データの手動送信
動作設定で、
バーコード読取後、自動的に送信する
に設定している場合、
手動で送信ボタンをタップして、遠隔キーボードに送信します。

操作ボタン | 説明
 | 読取データをPCに送信します。 自動的に送信する場合、タップしても反応しません。

送信ボタンをタップすると
● 遠隔キーボードに接続中
のダイアログを表示し、送信処理を実行します。

送信処理実行後、成功・失敗の結果を
● 読取開始。停止ボタン
の背景色に反映します。

読取ボタン | 説明
 | 送信処理は成功し、次の読取を行います。
 | 送信処理は失敗し、次の読取を行います。 未送信一覧画面を確認してください。

読取データの自動送信
動作設定で、
バーコード読取後、自動的に送信する
に設定している場合、
バーコード読取後、自動的に遠隔キーボードに送信します。

● 遠隔キーボードに接続中
のダイアログを表示し、送信実行・終了後、
● 送信後待機時間（秒）
待機してから、次の読み取りに遷移します。

送信後待機時間が短すぎると、次の読み取りが即実行されてしまい、
PC側で処理できない場合がありますので、設定値にご注意ください。

送信成功・失敗の結果は手動操作と同じく
● 読取開始。停止ボタン
の背景色に反映します。


未送信一覧

一覧の表示

OverFlowメニューの[未送信一覧]をタップし、未送信一覧画面を表示します。

当画面では、送信に失敗した読取データの
● 送信日時
● バーコード内容
を古い順に一覧表示します。

未送信情報が存在しない場合は、未送信一覧画面を表示しません。

未送信データの再送信

再送信の対象行をロングタップし、未送信一覧中の選択行を画面表示し、
再送信・削除操作を選択します。

画面表示部 | 説明
タイトル | 送信日時を表示します。
表示内容 | バーコード内容を表示します。
操作ボタン | 説明
送信 | 選択行を再送信します。 成功した場合、選択行削除 失敗した場合、行末尾移動 未送信件数が0件となった場合、未送信一覧画面を閉じます。
削除 | 選択行を削除します。 未送信件数が0件となった場合、未送信一覧画面を閉じます。
キャンセル | 確認ダイアログを閉じます。

再送信の実行後、操作メッセージパネルに以下いずれかのメッセージを表示します。

正常メッセージ

異常メッセージ
Wi-Fi/モバイル通信を使用する場合、オフラインでないか確認してください。
Bluetooth通信を使用する場合、Bluetoothの有効有無を確認してください。
以下を確認してください。
・遠隔キーボードの起動有無
・動作設定のホスト名／ポート番号
・動作設定のデバイス名
動作設定の操作許可識別子が、遠隔キーボードの設定と異なる可能性があります。

未送信データの一括削除

[一括削除]ボタンをタップし、未送信一覧中の全データを一括削除します。

操作ボタン | 説明
削除 | 未送信情報を一括削除し、未送信一覧画面を閉じます。
キャンセル | 確認ダイアログを閉じます。


動作設定

設定画面の表示

OverFlowメニューの[動作設定]をタップし、動作設定画面を表示します。

設定内容の反映

[保存]ボタンをタップし、入力した設定値を保存します。

保存後、設定値を画面に反映するため、本アプリを再起動します。
保存された設定内容は、次回起動時も有効となります。

バーコード読取の設定値変更

カメラ撮影に関する設定を行います。

以下の設定値を変更することができます。

● 読取押下許可　(0～9秒後)

カメラ幅・高さを自動調整する
● カメラ幅　　　(100～999)
● カメラ高さ　　(100～999)

通信前後動作の設定値変更

通信前後動作の設定を行います。

以下の設定値を変更することができます。

バーコード読取後、自動的に送信する
● 送信後待機時間　(0～60秒)

英大文字に変換して送信する
英小文字に変換して送信する
データ終端に改行を付加して送信する
● 最大未送信件数　(0～100件)

遠隔キーボードの設定値変更

遠隔キーボードに関する設定を行います。

以下の設定値を変更することができます。

● 操作許可識別子　(英数20文字以内)

Wi-Fi/モバイル通信を使用する
● ホスト名　　　(ホスト名／IPアドレス)
● ポート番号　　(49512～65535)
● 接続待機時間　(0～60秒)
● 通信待機時間　(0～60秒)

Bluetooth通信を使用する
● デバイス名　　(ペア設定済のデバイス)

導入時の設定に戻す

変更した値を導入時の設定に戻します。

設定を初めからやり直したい場合にタップします。


ヘルプ

ヘルプの表示

OverFlowメニューの[ヘルプ]をタップし、ヘルプ画面を表示します。

携帯端末では容量制限の関係上、画像による説明などを割愛してます。

初期表示では、文字のサイズも少々小さく表示されますが、
拡大／縮小機能でサイズ調整してください。

ページを選択した後に目次に戻りたい場合は、[目次へ]ボタンをタップしてください。


アプリ情報

画面の表示

OverFlowメニューの[アプリ情報]をタップし、アプリ情報画面を表示します。

当画面では、以下の内容を確認できます。
● アプリ名
● アプリ提供者
● アプリバージョン


閉じる

メニューによる終了

OverFlowメニューの[閉じる]をタップし、本アプリを終了します。

戻るボタンによる終了

メイン画面で[戻る]ボタンを選択し、本アプリを終了します。